PDA

View Full Version : My Fry Is Missing



mkiv4ever
06-15-2009, 04:25 AM
I had several hundred maybe thousands of fry in a 500 gallon above ground pond and they have been in there for a week and a half and just today i checked and all are gone. But as i look closure i found all of them dead. I can see their basic structure of the body and thats it. i am so upset. can anyone tell me what happened.

tyco4357
06-15-2009, 09:38 AM
Probably too much ammonia and nitrite. It's hard to do a water change with that many fry. You might still have some that survived but don't see them. They need clean water constantly.

rainblood
06-15-2009, 01:25 PM
Ditto on ammonia

EricT
06-15-2009, 02:40 PM
poison??? maybe the neighbors kids poisoned them.

tyco4357
06-15-2009, 04:57 PM
The most fry I have had in my 400 gal baby vat is 260 babies of which 60 percent did not make it.

mkiv4ever
06-15-2009, 11:21 PM
I think my next batch i will seperate my water hyacinths with the eggs between two ponds. How often do you guys do a water change with fry. And how do you guys do the water change without destroying the babies.

jonathan
06-19-2009, 03:25 PM
same thing happned to me but my fry are at 2months old and about 1.5'' lost 23 so far. only one alive so far. Water is spot on friend was saying that the birds could have done something :confused:

stephen
06-19-2009, 04:28 PM
I think my next batch i will seperate my water hyacinths with the eggs between two ponds. How often do you guys do a water change with fry. And how do you guys do the water change without destroying the babies.

I run water continuously. I prolly have a couple 100,000 fry in this one tank alone. The water goes thru carbon filtration 1st to remove chlorine. Most of the fry that go thru the holes in the big tank stay in the second tank which has much smaller holes.